Quick links:

Add Metadata to the Document

Tag content using the Reading Order tool
Tag content using the Content Pane
Tagging Lists

Tagging Table of Contents

Creating Table of Contents Links

Tagging Tables
Using the Table Editor

Artifacting Elements (Elements that have no real value, like small designs)

Adding alt text

Properly tag elements and read order
Tagging unmarked annotations (links

Meet WCAG standards using Pac checker (Windows only)

Add Metadata to the Document

1. Open Document Properties
e Click on the Menu button.

e Select Document Properties from the dropdown menu.

2. Add Title

e In the Title field, enter an appropriate title for your document.
Example: B.S. in Human Resource Development Degree Plan

3. Add Author

e |n the Author field, enter the author's name or organization.
Example: College of Education & Human Development



4. Add Subject

e In the Subject field, provide a brief description.
Example: 2025 edition of the B.S. in Human Resource Development Degree Plan

5. Add Keywords (Optional)

e In the Keywords field, add relevant keywords to help with search engine optimization.
Example: Texas A&M Bachelors programs, Texas A&M degree plans, Human resource
development Texas A&M

6. Display Title on Open
e Go to the Initial View tab.

e In the Show dropdown menu, select Document Title instead of File Name.

7. Save Changes

e Click OK to save your changes.

Tag Content using the Reading Order tool

1. Open the Tags Pane
e Go to the right side of the screen and open the Tags pane.

e |[f there are no tags available or if the tags displayed are out of order, you'll need to add
them manually.

2. Prepare for Accessibility



e Go to the upper left corner and select "All Tools".

e Choose "Prepare for Accessibility".

3. Open the Reading Order Panel
e Click on "Fix Reading Order".

e The Reading Order panel will pop up.

4. Select and Tag Content
e Use your cursor to click and drag around the content you want to tag.
o Select a slightly larger area than you think you need.
e Tag the selected content by clicking the appropriate button:
o "Figure" for images
o "Heading 1" for main headings

o "Text Paragraph™ for body text

5. Tagging Tips
e Use heading tags like H1, H2, H3, etc., for proper structure.
o Do not skip heading levels. For example, if you use an H2, the next heading must
be either an H2 or an H3, not an H4.
e Use the "Figure" tag for all images.

e Use the "List" tag for list items.

e When selecting text, overlap lines above and below the content to ensure full
selection.

6. Check and Adjust Tags



e Open the Tags pane to view your tagged content.

e |f elements appear out of order, drag and rearrange them within the pane.

7. Deselect "Display Like Elements in a Single Block"
e Atthe bottom of the Reading Order panel, uncheck:
o "Display like elements in a single block™

e This lets you see and edit individual tags.

8. Validate and Finalize
e Review the tags tree to ensure all content is tagged appropriately.

e Make any needed adjustments to improve document accessibility.

Taqg Content using Content Pane (Do this if
Reading Order tagaing did not fix all tags

1. Open the Document

e Start with your PDF document open in Adobe Acrobat.

2. Create Empty Tags
e Open the Tags pane.
e Click the three-dot menu and select "Create Tags Root".

e Click again and choose "New Tag" to create tags for each content type:



o Figure
o H1
o Paragraph

o etfc.

3. Highlight the Tag

e In the Tags pane, click on the tag you want to populate (e.g., Figure).

4. Switch to the Content Pane

e Click on the Content pane button.

e Expand the file name and then the specific page containing the content.

5. Select Content

e Highlight the content you want to tag (e.g., an image or block of text).

6. Create Tag from Selection
e Return to the Tags pane.

e With the correct tag highlighted, click the three-dot menu and select "Create Tag from
Selection".

7. Repeat for All Content

e Repeat this process for each piece of content, ensuring everything is tagged
appropriately.



8. Save and Test
e Save your document.

e Test the tags using a screen reader to confirm correct application and accessibility.

Tagging Lists

1. Open the Document

e Navigate to the section of your PDF that contains the list you want to tag.

2. Open the Tags Pane
e Highlight a list item.
e Open the Tags pane.

e Choose "Find Tag from Selection” to check if the item is already tagged.

3. Prepare for Accessibility
e |[f the content is not tagged, go to:

o All Tools > Prepare for Accessibility > Fixed Reading Order

4. Tagging the List

Label the Bullet/Number



e Use the marquee tool to draw around the bullet or number.

e Tagit as text (use a P tag).

Tag the Text

e Draw a separate marquee around the text of the list item.

e Tag it as text (also with a P tag).

5. Adjust Tags

Change Tag Types

e In the Tags pane:
o Select all the bullet/number tags and change their type to Label.

o Select all the list item text tags and change their type to List Item Body.

6. Create List Structure

Organize the Tags

e Foreach list item:

o Create a "List Item" tag.

o Move the corresponding Label and List Item Body tags into it.
e Create a top-level "List" tag.

e Nest all List Item tags inside the List tag.



Taqgqing Table of Contents

1. Open the PDF in Acrobat

e Open your PDF document.
e Navigate to the Tags pane.

e Check whether the Table of Contents (TOC) is already tagged.

2. Prepare for Accessibility

e Goto:
All Tools > Prepare for Accessibility > Fix Reading Order

3. Tag the TOC Items

e Use your cursor to highlight the text of each TOC item.

e Click the "Text Paragraph" button to tag the highlighted text.

4. Adjust Tags

e In the Tags pane, select all of the newly created text tags.
e Right-click and choose "Properties".

e Change the tag type to Table of Contents Item (TOCI).

5. Create a TOC Tag



e Right-click above the first TOCI tag and choose "New Tag".
e Select "Table of Contents (TOC)" as the tag type.

e Move all TOCI tags underneath the new TOC tag.

6. Adjust Tag Size (Optional)

e Hold down the Control key and scroll with the mouse wheel to resize tags for better
visibility.

Creating Table of Contents Links

1. Create Destinations
e Navigate to the section you want to link to.
e Highlight the text (e.g., “Section 1: Introduction”).

e Open the Destinations pane:
Right-click in the navigation area > select Destinations.

e Click "Create New Destination" and name it (e.g., @1_Section 1: Introduction).

2. Link Table of Contents

e Return to the Table of Contents page.
e Highlight the text you want to link (e.g., “Section 1: Infroduction”).

e Right-click and choose "Create Link".



e In the dialog box:
o Set the link type to "Invisible Rectangle" for a cleaner look.
o Choose "Go to a page view", then click Next.

e Double-click the corresponding Destination (e.g., 91_Section 1: Introduction).

3. Verify Links

e Use the Edit PDF tool to inspect link properties.

e Confirm that each link points to the correct destination.

4. Tag Links

e Open the Tags pane.
e Make sure each Table of Contents item:
o Has alink tag.
o Includes a link OBJR object inside the tag.

e Use "Find Unmarked Links" (in the accessibility tools) to detect and fix any untagged
links.

5. Test with Assistive Technology

e Use a screen reader like JAWS to verify that all links are accessible and function
correctly.

Tagging Tables



1. Evaluate the Table

e Open your PDF document in Adobe Acrobat.
e Navigate to the page containing the table.

e |Instead of tagging one large table, break it down into smaller, manageable sections if
needed.

2. Open the Reading Order Panel
e Go to All Tools > Prepare for Accessibility > Fix Reading Order.

e Use your cursor to select individual areas of the table.

3. Tag Individual Cells

e Highlight the content of each table cell.
e Use the Reading Order panel to tag the selection as a Cell.

e Double-check each cell, especially those containing multiple paragraphs, to ensure
correct tagging.

4. Structure the Table

e Open the Tags pane.
e Create new Table Row (TR) tags for each row in the table.

e Move each Cell (TD) into the correct Table Row (TR) tag.

5. Create the Table Tag

e Create a new Table tag.



o Nest all Table Row (TR) tags inside the Table tag to complete the structure.

6. Handle Header Rows
e Make sure that header rows are properly tagged.

e (This topic will be covered in more detail in the next tutorial on using the Table Editor.)

7. Validate and Save

e Ensure the table structure is correct in the Tags pane.

e Save your document to keep the changes.

Using the Table Editor

1. Open the Document
e Open your PDF document in Adobe Acrobat.

e Navigate to the page with the table you want to edit.

2. Access the Tags Pane
e Go to View > Show/Hide > Navigation Panes > Tags.

e The Tags pane will appear, displaying the document’s tag structure.

3. Check for Accessibility Errors

e Go to All Tools > Prepare for Accessibility > Check for Accessibility.



e Review results, especially under the Tables category (e.g., header errors, regularity
issues).

4. Open Table Editor

e In the Tags pane, locate and select the table tag.

e Right-click the table tag and choose Table Editor.

5. Define Table Parts

e Inside the Table Editor, right-click and select Table Editor Options.
e Set colors to visually distinguish parts of the table:

o Header cells

o Data cells
e Enable helpful options:

o [%4 Show cells that span multiple rows or columns

o [%4 Show Cell Type

6. Set Header Cells

e Select the appropriate cells that should serve as headers.
e Right-click > Table Cell Properties.

e Set the cell type to Header and define the Scope (e.g., Column or Row).

7. Address Regularity Issues

e For merged cells, update the span attributes:



o Right-click the cell
o Choose Table Cell Properties

o Set the correct Column Span or Row Span

8. Validate Changes
e Close the Table Editor when finished.

e Re-run the accessibility checker to ensure all issues are resolved.

Artifacting Elements

Avoid Using the Background/Artifact Button

e Navigate to All Tools > Prepare for Accessibility > Fix Reading Order.

e | Do not use the Background/Artifact button — it contains a known bug that may
cause issues.

Method 1: Using the Content Pane

1. Open the Content Pane
o This displays the internal structure of your PDF, including every element.
2. Select Elements to Artifact

o Choose items like page headers, footers, or decorative elements that should be
excluded from the reading order.

3. Create Artifact



o Right-click the selected element and choose Create Artifact.
o Inthe Create Artifact dialog:
m Leave the Artifact Type as Page.

m Click OK.

Method 2: Using the Tags Pane

1. Open the Tags Pane
o Navigate to View > Show/Hide > Navigation Panes > Tags.
2. Locate the Element to Artifact

o ldentify non-essential elements such as redundant headings, logos, or page
numbers.

3. Change Tag to Artifact
o Right-click the tag and select Change Tag to Artifact.
o Inthe Create Artifact dialog:
m  Confirm your selection.

m Click OK.

Adding Alt Text

1. Open the PDF

e Launch Adobe Acrobat.



e Open the PDF document you want to make accessible.

2. Method 1: Using the Reading Order Tool

e Go to All Tools > Prepare for Accessibility > Fix Reading Order.
e In the Reading Order panel, locate the figure (image or graphic).
e Right-click on the figure and select Edit Alternate Text.

e Enter a meaningful description of the image and click OK.

3. Method 2: Using the Tags Pane

e Open the Tags pane:
View > Show/Hide > Navigation Panes > Tags.

e |Locate the <Figure> tag for the image.
e Right-click the figure tag and select Properties.
e In the Object Properties dialog, enter the alt text in the Alternate Text field.

e C(Click Close to save.

4. Method 3: Using the Accessibility Checker
e Navigate to All Tools > Prepare for Accessibility > Check for Accessibility.
e Run the accessibility check.

e Look for issues listed under Figures alternate text.



Right-click the error and select Fix.

Enter appropriate alternative text and click Save and Close.

5. Method 4: Using the Add Alternate Text Tool

Go to All Tools > Prepare for Accessibility > Add Alternate Text.
A dialog will appear showing figures one at a time.

Use the arrow buttons to navigate through figures.

Add alt text for each image as needed.

Click Save and Close when finished.

Properly Tag Elements and Read Order

1. Open the Tags Pane

In Adobe Acrobat, go to:
View > Show/Hide > Navigation Panes > Tags
(or use All Tools > Prepare for Accessibility > open Tags).

2. Adjust Tag Size (Optional)

To enlarge the tags display:

o Hold Ctrl (Windows) or Cmd (Mac) and scroll your mouse wheel.



o Oruse Ctrl +/ Ctrl - to zoom in and out.

3. Start at the Top

e Click on the first tag at the top of the tags tree to begin reviewing.

4. Navigate Through Tags
e Use the down arrow key to move sequentially through each tag.

e Confirm that the reading order matches the document’s visual and logical order.

5. Check and Adjust Order

e Look for elements that are out of sequence (e.g., a caption read after the body text).

e Drag and drop tags to reposition them where necessary.

6. Expand and Collapse Tags
e Use the right arrow key to expand a tag and view its contents (e.g., paragraphs, links).

e Use the left arrow key to collapse it.

7. Verify Headings



e Ensure heading elements are properly tagged (e.g., <H1>, <H2>, etc.) and follow a
logical hierarchy.

8. Create a Missing Document Tag (if needed)
e If there’s no <Document> tag:
o Right-click in the Tags pane and select New Tag.

o Choose Document as the tag type.

9. Nest Tags Under the Document Tag

e Select all top-level tags (e.g., Shift+click to select multiple).

e Drag and drop them under the new <Document> tag to ensure proper structure

Tagaing Unmarked Annotations

1. Open Accessibility Tools
e Click All Tools in Adobe Acrobat.
e Select Prepare for Accessibility.

e Click Check for Accessibility to run the checker.




2. Identify Unmarked Annotations

e In the Accessibility Checker results, locate the “Tagged Annotations — Failed”
category.

e This indicates the presence of untagged annotations, such as links.

3. Locate Unmarked Annotations
e Open the Tags pane (View > Show/Hide > Navigation Panes > Tags).
e Click the Tags button at the top of the tags tree.
e Click the three-dot menu (...) > choose Find.
e In the Find Element dialog:
o Choose Unmarked Annotations from the dropdown.
o Set the search scope to Document.

o Click Find to locate the first unmarked annotation.

4. Tag the Annotations
e When an unmarked annotation is found:
o Click Tag Element.
o In the dialog, choose Link as the tag type.

o Click OK, or press Enter to tag all found unmarked annotations sequentially.




5. Organize the Tags
e In the Tags pane:
o Locate the newly created <Link> tags.

o Move them under an appropriate structure, such as a Table of Contents (TOC)
tag, for clarity.

o If needed, nest the visible link text (often a <Span> or <P> tag) inside the

corresponding <Link> tag.

6. Validate and Confirm Compliance

e Re-run the Accessibility Checker:

o Go back to All Tools > Prepare for Accessibility > Check for Accessibility.
o Verify that the “Tagged Annotations” error no longer appears.

e Ensure all links are now properly tagged and functional for screen readers.

Checking PDF Compliance with the PAC
2024 Checker

This guide walks you through validating and fixing accessibility issues in a PDF using the PDF
Accessibility Checker (PAC) 2024, ensuring compliance with WCAG and PDF/UA standards.

+ 1. Open PAC 2024 Checker



e Launch the PAC 2024 application.
e Click the "Open document™ button.

e Select your PDF file to begin the compliance check.

+ 2. Run the Compliance Check
e PAC will automatically run its analysis.
e Click "Results in Detail" to view specific issues found in:
o Structure Elements
o Annotations
o Metadata (PDF/UA identifier)
o Logical Reading Order

o Tagged Content

+ 3. Fix Common Issues
£ Structure Elements
e Ensure:
o All <Note> tags have unique IDs.

o All figures have bounding boxes.

Fix in Adobe Acrobat:

e Open the Tags pane.



e |Locate and untag the problematic figure, then retag it to regenerate the bounding box.

%/ Annotations

e Add alternate descriptions to all hyperlinks and annotations.

Using Adobe Acrobat:

e Right-click a link tag in the Tags pane > Properties > Add Alternate Text.

& PDF/UA Identifier

e Ensure your document includes the PDF/UA identifier.

Set in Acrobat:

e Go to File > Properties.

e Under the Advanced tab, check the PDF/UA identifier option.

+ 4. Use Acrobat’s Preflight Tools
e Go to All Tools > Print Production > Preflight.
e Use the fix “Add unique ID to Note structure elements”.

e This ensures all note elements are correctly tagged and identifiable.

+ 5. Final Checks and Validation
e Reopen PAC 2024 and reload the document.

e \Verify all errors have been resolved:



o Figures are block-level and contain placement attributes.
o All annotations are properly tagged.

o The document passes all structural and metadata checks.

I save and Confirm

e Save your corrected PDF file in Adobe Acrobat.

e Run the PAC checker one final time to confirm full compliance.
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